re = /(?<=<\/a>).*?(leoshi)/m
str = 'Sample text for testing:<a href="http://www.baidu.com" title="leoshi">leoshi</a>ahdfd leoshi <a href="http://www.baidu.com" title="leoshi">leoshi</a>for details balala...
Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!
Sample text for testing:<a href="http://www.baidu.com" title="leoshi">leoshi</a>bbfd fdleoshi Sample text for testing:<a href="http://www.baidu.com" title="leoshi">leoshi</a>ahdfd leoshi <a href="http://www.baidu.com" title="leoshi">leoshi</a>for details balala...for details balala...
Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end