using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<\/a>).*?(leoshi)";
string input = @"Sample text for testing:<a href=""http://www.baidu.com"" title=""leoshi"">leoshi</a>ahdfd leoshi <a href=""http://www.baidu.com"" title=""leoshi"">leoshi</a>for details balala...
Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!
Sample text for testing:<a href=""http://www.baidu.com"" title=""leoshi"">leoshi</a>bbfd fdleoshi Sample text for testing:<a href=""http://www.baidu.com"" title=""leoshi"">leoshi</a>ahdfd leoshi <a href=""http://www.baidu.com"" title=""leoshi"">leoshi</a>for details balala...for details balala...
Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}