import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<\\/a>).*?(leoshi)";
final String string = "Sample text for testing:<a href=\"http://www.baidu.com\" title=\"leoshi\">leoshi</a>ahdfd leoshi <a href=\"http://www.baidu.com\" title=\"leoshi\">leoshi</a>for details balala...\n"
+ "Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!\n\n"
+ "Sample text for testing:<a href=\"http://www.baidu.com\" title=\"leoshi\">leoshi</a>bbfd fdleoshi Sample text for testing:<a href=\"http://www.baidu.com\" title=\"leoshi\">leoshi</a>ahdfd leoshi <a href=\"http://www.baidu.com\" title=\"leoshi\">leoshi</a>for details balala...for details balala...\n"
+ "Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}