package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(?\d{3}[-.)]\d{3}[-.]\d{4}`)
var str = `These are some phone numbers 917-555-1234. Also,you can call me at 646.555.1234 and ofcourse I'm always reachableat
(212)867-5309.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}