re = /\(?\d{3}[-.)]\d{3}[-.]\d{4}/m
str = 'These are some phone numbers 917-555-1234. Also,you can call me at 646.555.1234 and ofcourse I\'m always reachableat
(212)867-5309.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end