// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(?\d{3}[-.)]\d{3}[-.]\d{4}").unwrap();
let string = "These are some phone numbers 917-555-1234. Also,you can call me at 646.555.1234 and ofcourse I'm always reachableat
(212)867-5309.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}