import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(?\\d{3}[-.)]\\d{3}[-.]\\d{4}";
final String string = "These are some phone numbers 917-555-1234. Also,you can call me at 646.555.1234 and ofcourse I'm always reachableat\n"
+ "(212)867-5309.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}