#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\S\r\n]*Options[^\S\r\n]+-(?:Indexes|FollowSymLinks|Includes|ExecCGI)\b.*$"
Local $sString = "Options -Indexes -FollowSymLinks -Includes -ExecCGI" & @CRLF & _
"#Options -Indexes -FollowSymLinks -Includes -ExecCGI" & @CRLF & _
"<Directory "/web/htdocs">" & @CRLF & _
" Options -Indexes -FollowSymLinks -Includes -ExecCGI" & @CRLF & _
"<Directory "/web/htdocs"> Options -Indexes -FollowSymLinks -Includes -ExecCGI" & @CRLF & _
" RewriteOptions -tester" & @CRLF & _
" Options -Indexes -FollowSymLinks -Includes -ExecCGI"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")