re = /^[^\S\r\n]*Options[^\S\r\n]+-(?:Indexes|FollowSymLinks|Includes|ExecCGI)\b.*$/m
str = 'Options -Indexes -FollowSymLinks -Includes -ExecCGI
#Options -Indexes -FollowSymLinks -Includes -ExecCGI
<Directory "/web/htdocs">
Options -Indexes -FollowSymLinks -Includes -ExecCGI
<Directory "/web/htdocs"> Options -Indexes -FollowSymLinks -Includes -ExecCGI
RewriteOptions -tester
Options -Indexes -FollowSymLinks -Includes -ExecCGI'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end