using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\S\r\n]*Options[^\S\r\n]+-(?:Indexes|FollowSymLinks|Includes|ExecCGI)\b.*$";
string input = @"Options -Indexes -FollowSymLinks -Includes -ExecCGI
#Options -Indexes -FollowSymLinks -Includes -ExecCGI
<Directory ""/web/htdocs"">
Options -Indexes -FollowSymLinks -Includes -ExecCGI
<Directory ""/web/htdocs""> Options -Indexes -FollowSymLinks -Includes -ExecCGI
RewriteOptions -tester
Options -Indexes -FollowSymLinks -Includes -ExecCGI";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}