import re
regex = re.compile(r"^[^\S\r\n]*Options[^\S\r\n]+-(?:Indexes|FollowSymLinks|Includes|ExecCGI)\b.*$", flags=re.MULTILINE)
test_str = ("Options -Indexes -FollowSymLinks -Includes -ExecCGI\n"
"#Options -Indexes -FollowSymLinks -Includes -ExecCGI\n"
"<Directory \"/web/htdocs\">\n"
" Options -Indexes -FollowSymLinks -Includes -ExecCGI\n"
"<Directory \"/web/htdocs\"> Options -Indexes -FollowSymLinks -Includes -ExecCGI\n"
" RewriteOptions -tester\n"
" Options -Indexes -FollowSymLinks -Includes -ExecCGI")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")