import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\S\\r\\n]*Options[^\\S\\r\\n]+-(?:Indexes|FollowSymLinks|Includes|ExecCGI)\\b.*$";
final String string = "Options -Indexes -FollowSymLinks -Includes -ExecCGI\n"
+ "#Options -Indexes -FollowSymLinks -Includes -ExecCGI\n"
+ "<Directory \"/web/htdocs\">\n"
+ " Options -Indexes -FollowSymLinks -Includes -ExecCGI\n"
+ "<Directory \"/web/htdocs\"> Options -Indexes -FollowSymLinks -Includes -ExecCGI\n"
+ " RewriteOptions -tester\n"
+ " Options -Indexes -FollowSymLinks -Includes -ExecCGI";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}