// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\S\r\n]*Options[^\S\r\n]+-(?:Indexes|FollowSymLinks|Includes|ExecCGI)\b.*$").unwrap();
let string = "Options -Indexes -FollowSymLinks -Includes -ExecCGI
#Options -Indexes -FollowSymLinks -Includes -ExecCGI
<Directory \"/web/htdocs\">
Options -Indexes -FollowSymLinks -Includes -ExecCGI
<Directory \"/web/htdocs\"> Options -Indexes -FollowSymLinks -Includes -ExecCGI
RewriteOptions -tester
Options -Indexes -FollowSymLinks -Includes -ExecCGI";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}