import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<(img|br)([^>]*)(?<!\\/)>";
final String string = " <img alt=\"\" height=\"239\" src=\"http://example.com/image.png\" width=\"272\"/>\n"
+ " <img alt=\"\" height=\"239\" src=\"http://example.com/image.png\" width=\"272\">\n"
+ "<br>";
final String subst = "<\\1\\2/>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}