import Foundation
let pattern = #"\<(img|br)([^>]*)(?<!\/)>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<img alt="" height="239" src="http://example.com/image.png" width="272"/>
<img alt="" height="239" src="http://example.com/image.png" width="272">
<br>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<\1\2/>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)