$re = '/\<(img|br)([^>]*)(?<!\/)>/';
$str = ' <img alt="" height="239" src="http://example.com/image.png" width="272"/>
<img alt="" height="239" src="http://example.com/image.png" width="272">
<br>';
$subst = "<\1\2/>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;