use strict;
my $str = ' <img alt="" height="239" src="http://example.com/image.png" width="272"/>
<img alt="" height="239" src="http://example.com/image.png" width="272">
<br>';
my $regex = qr/\<(img|br)([^>]*)(?<!\/)>/p;
my $subst = '<\\1\\2/>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";