const regex = /\<(img|br)([^>]*)(?<!\/)>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<(img|br)([^>]*)(?<!\\\/)>', 'g')
const str = ` <img alt="" height="239" src="http://example.com/image.png" width="272"/>
<img alt="" height="239" src="http://example.com/image.png" width="272">
<br>`;
const subst = `<\1\2/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);