re = /\<(img|br)([^>]*)(?<!\/)>/
str = ' <img alt="" height="239" src="http://example.com/image.png" width="272"/>
<img alt="" height="239" src="http://example.com/image.png" width="272">
<br>'
subst = '<\\1\\2/>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result