# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=(([^"]*"){2})*[^"]*$),/;/g;t' <<< "foo bar,\"3,14\",\"1,000,000\",hippo,\"cat,dog,frog\",plain text,\"2,25\""