use strict;
my $str = 'foo bar,"3,14","1,000,000",hippo,"cat,dog,frog",plain text,"2,25"';
my $regex = qr/(?=(([^"]*"){2})*[^"]*$),/p;
my $subst = ';';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";