re = /(?=(([^"]*"){2})*[^"]*$),/
str = 'foo bar,"3,14","1,000,000",hippo,"cat,dog,frog",plain text,"2,25"'
subst = ';'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result