import Foundation
let pattern = #"(?=(([^"]*"){2})*[^"]*$),"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"foo bar,"3,14","1,000,000",hippo,"cat,dog,frog",plain text,"2,25""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #";"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)