const regex = /(?=(([^"]*"){2})*[^"]*$),/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(([^"]*"){2})*[^"]*$),', 'g')
const str = `foo bar,"3,14","1,000,000",hippo,"cat,dog,frog",plain text,"2,25"`;
const subst = `;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);