# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\s]+(?![^><]*>)//gm;t' <<< "<root>
<result success=\"1\"/>
<userID>12345</userID>
<classID>56543</classID>
</root>"