#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[\s]+(?![^><]*>)"
Local $sString = "<root>" & @CRLF & _
" <result success="1"/>" & @CRLF & _
" <userID>12345</userID>" & @CRLF & _
" <classID>56543</classID>" & @CRLF & _
"</root>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)