use strict;
my $str = '<root>
<result success="1"/>
<userID>12345</userID>
<classID>56543</classID>
</root>';
my $regex = qr/[\s]+(?![^><]*>)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";