import Foundation
let pattern = #"[\s]+(?![^><]*>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<root>
<result success="1"/>
<userID>12345</userID>
<classID>56543</classID>
</root>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)