using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\s]+(?![^><]*>)";
string substitution = @"";
string input = @"<root>
<result success=""1""/>
<userID>12345</userID>
<classID>56543</classID>
</root>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}