$re = '/[\s]+(?![^><]*>)/m';
$str = '<root>
<result success="1"/>
<userID>12345</userID>
<classID>56543</classID>
</root>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;