#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\+]?[1]?[\s]?(\d{3}|\(\d{3}\)))[\-|\s]?\d{3}[\-|\s]?\d{4}$"
Local $sString = "(555)" & @CRLF & _
"555-555-5555" & @CRLF & _
"(555)555-5555" & @CRLF & _
"(555) 555-5555" & @CRLF & _
"555 555 5555" & @CRLF & _
"5555555555" & @CRLF & _
"" & @CRLF & _
"1-(555)5555555" & @CRLF & _
"555555555" & @CRLF & _
"55 555 5555" & @CRLF & _
"+1555 5555555" & @CRLF & _
"1 555 555 5555" & @CRLF & _
"1 (555) 555-5555" & @CRLF & _
"-1 (757) 622-7382" & @CRLF & _
"+1 (757) 622-7382" & @CRLF & _
"123**&!!asdf#" & @CRLF & _
"(6505552368)" & @CRLF & _
"1 555)555-5555" & @CRLF & _
"1 (555 555-5555" & @CRLF & _
"(555-555-5555" & @CRLF & _
"" & @CRLF & _
"(\+|\+1|\+1\-|1\-|1)?(\s)?((\([0-9]{3}\)|[0-9]{3}))(\s|\-)([0-9]{3})(\s|\-)?([0-9]{3,4})" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(?:(?:\+?" & @CRLF & _
"1" & @CRLF & _
"\s*" & @CRLF & _
"(?:[.-]\s*)?)?" & @CRLF & _
"(?:\(\s*([2-9]1[02-9]|[2-9][02-8]1|" & @CRLF & _
"[2-9][02-8][02-9])\s*\)|" & @CRLF & _
"(" & @CRLF & _
"[2-9]1[02-9]|" & @CRLF & _
"[2-9][02-8]1|" & @CRLF & _
"[2-9][02-8][02-9]))\s*" & @CRLF & _
"(?:[.-]\s*)?" & @CRLF & _
")?" & @CRLF & _
"([2-9]1[02-9]|[2-9][02-9]1|[2-9][02-9]{2})\s*(?:[.-]\s*)?" & @CRLF & _
"([0-9]{4})" & @CRLF & _
"(?:\s*(?:#|x\.?|ext\.?|extension)\s*" & @CRLF & _
"(\d+)" & @CRLF & _
")?" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")