import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\+]?[1]?[\\s]?(\\d{3}|\\(\\d{3}\\)))[\\-|\\s]?\\d{3}[\\-|\\s]?\\d{4}$";
final String string = "(555)\n"
+ "555-555-5555\n"
+ "(555)555-5555\n"
+ "(555) 555-5555\n"
+ "555 555 5555\n"
+ "5555555555\n\n"
+ "1-(555)5555555\n"
+ "555555555\n"
+ "55 555 5555\n"
+ "+1555 5555555\n"
+ "1 555 555 5555\n"
+ "1 (555) 555-5555\n"
+ "-1 (757) 622-7382\n"
+ "+1 (757) 622-7382\n"
+ "123**&!!asdf#\n"
+ "(6505552368)\n"
+ "1 555)555-5555\n"
+ "1 (555 555-5555\n"
+ "(555-555-5555\n\n"
+ "(\\+|\\+1|\\+1\\-|1\\-|1)?(\\s)?((\\([0-9]{3}\\)|[0-9]{3}))(\\s|\\-)([0-9]{3})(\\s|\\-)?([0-9]{3,4})\n\n\n"
+ "(?:(?:\\+?\n"
+ "1\n"
+ "\\s*\n"
+ "(?:[.-]\\s*)?)?\n"
+ "(?:\\(\\s*([2-9]1[02-9]|[2-9][02-8]1|\n"
+ "[2-9][02-8][02-9])\\s*\\)|\n"
+ "(\n"
+ "[2-9]1[02-9]|\n"
+ "[2-9][02-8]1|\n"
+ "[2-9][02-8][02-9]))\\s*\n"
+ "(?:[.-]\\s*)?\n"
+ ")?\n"
+ "([2-9]1[02-9]|[2-9][02-9]1|[2-9][02-9]{2})\\s*(?:[.-]\\s*)?\n"
+ "([0-9]{4})\n"
+ "(?:\\s*(?:#|x\\.?|ext\\.?|extension)\\s*\n"
+ "(\\d+)\n"
+ ")?\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}