re = /^([\+]?[1]?[\s]?(\d{3}|\(\d{3}\)))[\-|\s]?\d{3}[\-|\s]?\d{4}$/m
str = '(555)
555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1-(555)5555555
555555555
55 555 5555
+1555 5555555
1 555 555 5555
1 (555) 555-5555
-1 (757) 622-7382
+1 (757) 622-7382
123**&!!asdf#
(6505552368)
1 555)555-5555
1 (555 555-5555
(555-555-5555
(\\+|\\+1|\\+1\\-|1\\-|1)?(\\s)?((\\([0-9]{3}\\)|[0-9]{3}))(\\s|\\-)([0-9]{3})(\\s|\\-)?([0-9]{3,4})
(?:(?:\\+?
1
\\s*
(?:[.-]\\s*)?)?
(?:\\(\\s*([2-9]1[02-9]|[2-9][02-8]1|
[2-9][02-8][02-9])\\s*\\)|
(
[2-9]1[02-9]|
[2-9][02-8]1|
[2-9][02-8][02-9]))\\s*
(?:[.-]\\s*)?
)?
([2-9]1[02-9]|[2-9][02-9]1|[2-9][02-9]{2})\\s*(?:[.-]\\s*)?
([0-9]{4})
(?:\\s*(?:#|x\\.?|ext\\.?|extension)\\s*
(\\d+)
)?
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end