use strict;
my $str = '(555)
555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1-(555)5555555
555555555
55 555 5555
+1555 5555555
1 555 555 5555
1 (555) 555-5555
-1 (757) 622-7382
+1 (757) 622-7382
123**&!!asdf#
(6505552368)
1 555)555-5555
1 (555 555-5555
(555-555-5555
(\\+|\\+1|\\+1\\-|1\\-|1)?(\\s)?((\\([0-9]{3}\\)|[0-9]{3}))(\\s|\\-)([0-9]{3})(\\s|\\-)?([0-9]{3,4})
(?:(?:\\+?
1
\\s*
(?:[.-]\\s*)?)?
(?:\\(\\s*([2-9]1[02-9]|[2-9][02-8]1|
[2-9][02-8][02-9])\\s*\\)|
(
[2-9]1[02-9]|
[2-9][02-8]1|
[2-9][02-8][02-9]))\\s*
(?:[.-]\\s*)?
)?
([2-9]1[02-9]|[2-9][02-9]1|[2-9][02-9]{2})\\s*(?:[.-]\\s*)?
([0-9]{4})
(?:\\s*(?:#|x\\.?|ext\\.?|extension)\\s*
(\\d+)
)?
';
my $regex = qr/^([\+]?[1]?[\s]?(\d{3}|\(\d{3}\)))[\-|\s]?\d{3}[\-|\s]?\d{4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}