# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([\+]?[1]?[\s]?(\d{3}|\(\d{3}\)))[\-|\s]?\d{3}[\-|\s]?\d{4}$"
test_str = ("(555)\n"
"555-555-5555\n"
"(555)555-5555\n"
"(555) 555-5555\n"
"555 555 5555\n"
"5555555555\n\n"
"1-(555)5555555\n"
"555555555\n"
"55 555 5555\n"
"+1555 5555555\n"
"1 555 555 5555\n"
"1 (555) 555-5555\n"
"-1 (757) 622-7382\n"
"+1 (757) 622-7382\n"
"123**&!!asdf#\n"
"(6505552368)\n"
"1 555)555-5555\n"
"1 (555 555-5555\n"
"(555-555-5555\n\n"
"(\\+|\\+1|\\+1\\-|1\\-|1)?(\\s)?((\\([0-9]{3}\\)|[0-9]{3}))(\\s|\\-)([0-9]{3})(\\s|\\-)?([0-9]{3,4})\n\n\n"
"(?:(?:\\+?\n"
"1\n"
"\\s*\n"
"(?:[.-]\\s*)?)?\n"
"(?:\\(\\s*([2-9]1[02-9]|[2-9][02-8]1|\n"
"[2-9][02-8][02-9])\\s*\\)|\n"
"(\n"
"[2-9]1[02-9]|\n"
"[2-9][02-8]1|\n"
"[2-9][02-8][02-9]))\\s*\n"
"(?:[.-]\\s*)?\n"
")?\n"
"([2-9]1[02-9]|[2-9][02-9]1|[2-9][02-9]{2})\\s*(?:[.-]\\s*)?\n"
"([0-9]{4})\n"
"(?:\\s*(?:#|x\\.?|ext\\.?|extension)\\s*\n"
"(\\d+)\n"
")?\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.