import Foundation
let pattern = #"^([\+]?[1]?[\s]?(\d{3}|\(\d{3}\)))[\-|\s]?\d{3}[\-|\s]?\d{4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
(555)
555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1-(555)5555555
555555555
55 555 5555
+1555 5555555
1 555 555 5555
1 (555) 555-5555
-1 (757) 622-7382
+1 (757) 622-7382
123**&!!asdf#
(6505552368)
1 555)555-5555
1 (555 555-5555
(555-555-5555
(\+|\+1|\+1\-|1\-|1)?(\s)?((\([0-9]{3}\)|[0-9]{3}))(\s|\-)([0-9]{3})(\s|\-)?([0-9]{3,4})
(?:(?:\+?
1
\s*
(?:[.-]\s*)?)?
(?:\(\s*([2-9]1[02-9]|[2-9][02-8]1|
[2-9][02-8][02-9])\s*\)|
(
[2-9]1[02-9]|
[2-9][02-8]1|
[2-9][02-8][02-9]))\s*
(?:[.-]\s*)?
)?
([2-9]1[02-9]|[2-9][02-9]1|[2-9][02-9]{2})\s*(?:[.-]\s*)?
([0-9]{4})
(?:\s*(?:#|x\.?|ext\.?|extension)\s*
(\d+)
)?
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)