const regex = /[^a-zA-Z0-9\p{Cyrillic} ]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z0-9\\p{Cyrillic} ]', '')
const str = `қасымалы дияр abcdef
test NbТитаренко`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);