$re = '/[^a-zA-Z0-9\p{Cyrillic} ]/';
$str = 'қасымалы дияр abcdef
test NbТитаренко';
$subst = "-";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;