re = /[^a-zA-Z0-9\p{Cyrillic} ]/
str = 'қасымалы дияр abcdef
test NbТитаренко'
subst = '-'
result = str.sub(re, subst)
# Print the result of the substitution
puts result