use strict;
my $str = 'қасымалы дияр abcdef
test NbТитаренко';
my $regex = qr/[^a-zA-Z0-9\p{Cyrillic} ]/p;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";