# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\n\r]*<p> <\\/p>)*$//gi;t' <<< "<p>texxxxxxxxxxt1</p>
<p> </p>
<p>textttttttttt2</p>
<p> </p>
<p> </p>
<p>teeeeeeeeeext3</p>
<p> </p>
<p> </p>
<p> </p>
<p> </p>
<p> </p>"