const regex = /([\n\r]*<p> <\/p>)*$/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\n\\r]*<p> <\\\/p>)*$', 'gi')
const str = `<p>texxxxxxxxxxt1</p>
<p> </p>
<p>textttttttttt2</p>
<p> </p>
<p> </p>
<p>teeeeeeeeeext3</p>
<p> </p>
<p> </p>
<p> </p>
<p> </p>
<p> </p>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);