import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\n\\r]*<p> <\\/p>)*$";
final String string = "<p>texxxxxxxxxxt1</p>\n"
+ "<p> </p>\n"
+ "<p>textttttttttt2</p>\n"
+ "<p> </p>\n"
+ "<p> </p>\n"
+ "<p>teeeeeeeeeext3</p>\n"
+ "<p> </p>\n"
+ "<p> </p>\n"
+ "<p> </p>\n"
+ "<p> </p>\n"
+ "<p> </p>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}