import Foundation
let pattern = #"([\n\r]*<p> <\/p>)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<p>texxxxxxxxxxt1</p>
<p> </p>
<p>textttttttttt2</p>
<p> </p>
<p> </p>
<p>teeeeeeeeeext3</p>
<p> </p>
<p> </p>
<p> </p>
<p> </p>
<p> </p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)