$re = '/([\n\r]*<p> <\/p>)*$/i';
$str = '<p>texxxxxxxxxxt1</p>
<p> </p>
<p>textttttttttt2</p>
<p> </p>
<p> </p>
<p>teeeeeeeeeext3</p>
<p> </p>
<p> </p>
<p> </p>
<p> </p>
<p> </p>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;