#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)([\n\r]*<p> <\/p>)*$"
Local $sString = "<p>texxxxxxxxxxt1</p>" & @CRLF & _
"<p> </p>" & @CRLF & _
"<p>textttttttttt2</p>" & @CRLF & _
"<p> </p>" & @CRLF & _
"<p> </p>" & @CRLF & _
"<p>teeeeeeeeeext3</p>" & @CRLF & _
"<p> </p>" & @CRLF & _
"<p> </p>" & @CRLF & _
"<p> </p>" & @CRLF & _
"<p> </p>" & @CRLF & _
"<p> </p>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)