#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\byou+()|u+s"
Local $sString = "you youyou youyouyou u uu uuu Can't wait to see youuuu uuuuyou youuuuuyou uuyouuu you you youyou youyouyou u uu uuu Can't wait to see youuuu uuuuyou youuuuuyou uuyouuu" & @CRLF & _
"" & @CRLF & _
" I want to film the bayou with you and put it on youtube,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")