using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\byou+()|u+s";
string input = @"you youyou youyouyou u uu uuu Can't wait to see youuuu uuuuyou youuuuuyou uuyouuu you you youyou youyouyou u uu uuu Can't wait to see youuuu uuuuyou youuuuuyou uuyouuu
I want to film the bayou with you and put it on youtube,";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}