const regex = /\byou+()|u+s/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\byou+()|u+s', 'g')
const str = `you youyou youyouyou u uu uuu Can't wait to see youuuu uuuuyou youuuuuyou uuyouuu you you youyou youyouyou u uu uuu Can't wait to see youuuu uuuuyou youuuuuyou uuyouuu
I want to film the bayou with you and put it on youtube,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}