package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\byou+()|u+s`)
var str = `you youyou youyouyou u uu uuu Can't wait to see youuuu uuuuyou youuuuuyou uuyouuu you you youyou youyouyou u uu uuu Can't wait to see youuuu uuuuyou youuuuuyou uuyouuu
I want to film the bayou with you and put it on youtube,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}